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Plan your Web site

Determine goal.

Make it specific, if necessary.

Keep it short and focused.

Know your audience.

1.

Sketch site structure.2.

Sketch a common page layout.3.

Find a Web server
To find a Web server, do one of the following:

If you want your site on the World Wide Web, search for a Web site hosting company using your favorite search engine. 

Or, go to the Locate a Web Presence Provider Web site.

If you want your site on your company's intranet, then your IT department may have a server you can use. It's also possible that your 
very own computer could be configured as a Web server. For details, you'll want to consult your IT department, your manager, or the 
nearest computer guru.

Get server details
Once you've found a server for your site, make sure to get the following information before you start designing your site:

URL    For example: http://www.adventure-works.com

Correct file name for your home page    index.htm, index.html, default.htm, or default.html

Publishing destination    http:// path or ftp:// path

User name and password   

Server restrictions    File size limit? Other restrictions?

Create a Web site
If you made a Web site using a third-party program (for example, Macromedia® Dreamweaver® or HomeSite™), you can convert that Web site
to a Microsoft FrontPage® Web site by clicking the Open Site command on the File menu. If you need to start from scratch, the following
steps will guide you through the process.

On the File menu, click New.1.

In the New task pane, click either One page Web site or More Web site templates.2.

If you want a Web site based on a pre-made template, choose a template on the left. You can also choose the Empty Web Site
template if you don't need a pre-made Web site.

3.

Do one of the following:

To create a new disk-based site, click the Browse button. Browse to a location on your computer where you want to store the

Web site. When you've found the location you want, click the Create New Folder button  , type a name for the Web site, 
and then click OK. Click the Open button, and then click OK.

To create a server-based site, type the URL for the new Web site in the Specify the location of the new Web site box, and 
then click OK. Note that a server-based site can only be created on a Web server running FrontPage Server Extensions from 
Microsoft or Microsoft SharePoint® Services.

4.

How to quickly create a Web page

Create a new Web page, and give it a layout

Along the left side of your screen should be the Folder List. It shows all the files and folders in the site. (If the Folder List isn't 1.
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visible, click the Toggle Pane button  .)

At the top of the Folder List, click the New Page button.2.

Name the new page, and then press ENTER.3.

Double-click the new page to open it.4.

Now close the Folder List to give yourself more room. To close the Folder List, click the Toggle Pane button  .5.

Now make sure that the Layout Tables and Cells task pane is open on the right. If you don't see it, click Layout Table and Cells
on the Table menu.

6.

At the bottom of the task pane is a list of layouts to choose from. Click a layout to apply it to the page.7.

Modify the layout

If you'd like, you can change the alignment of the layout. In the Layout Tables and Cells task pane, under Table Properties, click 

the Align Center button  .

1.

Before changing the size of the layout, make sure to select the Auto-scale cells with table check box in the Layout Tables and 
Cells task pane. When you resize a table, this setting will allow you to automatically resize the cells inside as well.

2.

Now you'll resize the layout table to suit your design. In the Width box, type a value in pixels, and then press ENTER. Do the same in 
the Height box.

3.

Add an image

Click inside a cell.1.

On the Insert menu, point to Picture, and then click From File.2.

At the top of the dialog box, click the Look in box, to expand it. 3.

Then browse your computer to find the picture.4.

Click the picture, and then click the Insert button.5.

Add text

To add text, you can type or copy and paste from other files or programs. Or, you can import text from a Microsoft Word document.

On the Insert menu, click File.1.

At the bottom of the dialog box, click the Files of type box to expand it, and then click Word 97-2003 (*.doc) in the list.2.

Locate the document on your computer.3.

Double-click the Word document to import the text.4.

Insert a hyperlink

Select either text or a picture.1.

On the Insert menu, click Hyperlink. 2.

On the left, click Existing File or Web Page.3.

Select a page, and then click OK.4.

Add a background to the page

On the File menu, click Properties.1.

Click the Formatting tab.2.

Select the Background picture check box, and then click the Browse button.3.

Locate an image file on your computer.4.

Select the image, and then click Open.5.

Click OK.6.

Add a background image that is not tiled across the page

On the Format menu, click Style.1.
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In the lower-left area of the dialog box, under List, make sure that HTML tags is selected.2.

In the Styles list, double-click body.3.

Click the Format button, and then click Border in the list.4.

Click the Shading tab.5.

In the Background picture box, type the path to the picture.6.

Select no-repeat in the Repeat list.7.

Click OK three times.8.

Additional information

More information about using tables for page layout

This course only touched the tip of the iceberg when it comes to using HTML tables for page layout. See these other training courses for more in 
depth information:

Course What you’ll learn

HTML Tables I: Basic concepts Table basics: How to insert a simple HTML table, what table tags are 
like, and how to change 
table properties

HTML Tables II: Table and cell widths More basics: How HTML table and cell widths work, and how to make 
them look the way you want

HTML Tables III: Design a page with layout tables The fun stuff: How to use layout tables to design a page, and how to 
use a tracing image to start 
your layout

HTML Tables IV: Format and touch up a page layout Finishing touches: How to format a layout table, how to add color, 
style, and finesse like a pro, and how to make your table stretch

Other page layout techniques

You can also use layers for page layout. Frames is another technique you can use as well. Check out the following for more information:

Layers

Frames

More information on styles

If you would like to learn more about customizing your pages with cascading style sheets, check out these resources:

About styles

Create a cascading style sheet

Add a style to a cascading style sheet

Link to an external cascading style sheet

Apply a style
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Insert hyperlinks
To insert a hyperlink:

Select either some text or a picture.1.

Click the Insert menu.2.

Click Hyperlink. Then choose a destination option from the Insert Hyperlink dialog box.3.

Tip    The shortcut key for inserting hyperlinks is CTRL+K.

URL syntax

   Protocol

   Web server

   Path

   File name

   Anchor

Recalculate hyperlinks

Managing files in a Web site

If you have a Microsoft® FrontPage® Web site and you add, edit, move,
or rename files outside of FrontPage, remember to recalculate hyperlinks. 
This allows FrontPage to catch up with your changes.

To recalculate hyperlinks

   Click the Tools menu.

   Click Recalculate Hyperlinks.

Fix broken hyperlinks

The Broken Hyperlinks Report lets you find and fix broken internal links, and verify external links.

On the View menu, point to Reports, then click Site Summary.1.

In the list of reports, click Broken Hyperlinks.2.

If you have any external links in your Web site, FrontPage will ask if you want to verify those links. Click Yes to verify them.3.

One or more of the following may occur:

Internal links that go to missing or misspelled pages will have Broken status. As shown here, when you double-click a 

4.
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broken link, you can either type the right file name or browse to the correct location.

FrontPage will attempt to verify any external links. If links go to valid and available Web sites, they will have OK status. A 
link will have Broken status if the Web site is invalid or unavailable, or if your connection to the Internet was unavailable.
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To insert a link bar with custom links
Note    Link bars won't work on the Web unless you publish your Web site to a Web server running FrontPage® 2002 Server Extensions from
Microsoft, SharePoint™ Team Services 1.0 from Microsoft, or Microsoft Windows® SharePoint Services.

If you're not already in Design view, click the Design button  at the bottom of the page.1.

Position the insertion point where you want to place the link bar.2.

On the Insert menu, click Web Component. In the left pane, click Link Bars, and in the right pane, double-click Bar with custom 
links.

Note    This command is unavailable if you don't have a FrontPage Web site open.

3.

Select the link bar style you want to use for this link bar. Or, if your page uses a theme, click Use Page's Theme.

If a theme has been applied to your Web site, link bars will use fonts, colors, and other style elements from the theme. If you click Use 
Page's Theme and your page does not use a theme, the link bar will use the default text style of the page.

4.

Click Next. Then choose the orientation of the link bar and click Finish.5.

One of the following will happen: 

If you haven't created a link bar for your site yet, the Create New Link Bar dialog box appears. Type a name for your new 
link bar, and then click OK. Then use the Add link, Remove link, Move up, and Move down buttons to customize your link 
bar.

If you have created a link bar for your site, the Link Bar Properties dialog box appears. If you want to reuse a link bar, 
choose a link bar name under Choose existing. If you don't want to reuse a previously made link bar, click Create new. 
Then type a name for your new link bar and click OK. Use the Add link, Remove link, Move up, and Move down buttons 
to customize your link bar.

6.

To insert a link bar with Back and Next buttons

If you're not already in Design view, click the Design button  at the bottom of the page.1.

Position the insertion point where you want to place the link bar.2.

On the Insert menu, click Web Component. In the left pane, click Link Bars, and in the right pane, double-click Bar with back 
and next links.

3.

Select the link bar style you want to use for this link bar. Or, if your page uses a theme, click Use Page's Theme.

If a theme has been applied to your Web site, link bars will use fonts, colors, and other style elements from the theme. If you click Use 
Page's Theme and your page does not use a theme, the link bar will use the default text style of the page.

4.

Click Next. Then choose the orientation of the link bar and click Finish.5.

One of the following will happen: 

If you haven't created a link bar for your site yet, the Create New Link Bar dialog box appears. Type a name for your new 
link bar, and then click OK. Then use the Add link button to add pages that need the link bar. Use the Move up and Move 
down buttons as necessary to set the order in which the pages should be browsed.

If you have created a link bar for your site, the Link Bar Properties dialog box appears. If you want to reuse a link bar, 
choose a link bar name under Choose existing. If you don't want to reuse a previously made link bar, click Create new. 
Then type a name for your new link bar and click OK. Use the Add link button to add pages that need the link bar. Use the 
Move up and Move down buttons as necessary to set the order in which the pages should be browsed.

6.

To create an image map

If you're not already in Design view, click the Design button  at the bottom of the page.1.

Select the picture you want to use as an image map.2.

On the Pictures toolbar, click the Hotspot button corresponding to the shape you want.

Note    To display the Pictures toolbar, point to Toolbars on the View menu and then click Pictures.

Rectangular Hotspot 

Circular Hotspot 

Polygon Hotspot 

Note    To draw a polygon, click where you want the first corner of the polygon to be, click to place each corner of the polygon, and
then double click to finish it

3.
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Working with Graphics in FrontPage

Choose the right file 
format

GIFs:

Should have less than 256 colors.

Are best for line drawings, logos, or illustrations.

Can have a transparent background.

JPEGs:

Should have more than 256 colors.

Are best for photographs.

Cannot have a transparent background.

PNGs:

Can have more or less than 256 colors.

Can have a transparent background.

However, PNGs are not supported by many browsers.

Insert a graphic
On the Insert menu, point to Picture, and then click From File.1.

At the top of the dialog box, click the Look in box, to expand it.2.

Browse your computer to find the graphic you want.3.

Work with the Save 
Embedded Files dialog 
box

   If the Action column says Save, this means that FrontPage will save a copy of the graphic after you click 
OK.

   Under Folder is a suggested location for the copy. This area will often appear blank. This means that 
FrontPage will put the copy of the graphic in the root folder for the Web site.

   The Name column will show the file name for the graphic. This may change if you insert a graphic that is
not a GIF, JPEG, or PNG.

Edit the image To edit the image in FrontPage, select the graphic. Then click the View menu, point to the Toolbars
submenu, and then click Pictures.

To edit the image in another program, right-click the graphic, select Open With, and then choose 
the program you want.
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What is a style sheet
A style sheet is a set of instructions (rules) that tells a browser how to present HTML elements, such as what font to use, what size the 
paragraph text should be, what color the header text should be, whether or not there should be a background color applied to specific 
elements, and so on.

Syntax for a style rule

Each style rule is made up of two parts: the selector and the definition. The selector identifies the element affected by the rule, and the 
definition identifies how the element will be displayed. The definition contains the property and the value of the element. For example, if 
the property is color, the value might be blue.

selector { property: value; }

Types of cascading style sheets
External style sheet

Embedded style sheet

Inline style sheet

External style sheet
Also called a linked style sheet in FrontPage, you use an external style sheet when you want to apply the same styles consistently 
across all the pages in your Web site that are linked to it.

The link from a Web page to a style sheet is included in the document header (between the <head> and </head> tags using the <link> 
tag:

<link rel="stylesheet" type="text/css" href="styles.css">

Your style sheet would include the actual style definitions, such as: h1 {color: blue; }

How to create an external style sheet

On the File menu, click New.1.

On the New task pane, under New page, click More page templates.2.

In the Page Templates dialog box, click the Style Sheets tab.3.

Click Normal Style Sheet, and then click OK.4.

How to link to an external style sheet

On the Format menu, click Style Sheet Links.1.

In the Link Style Sheet dialog box, clic Add.2.

In the Select File dialog box, click the style sheet you want to link to and click OK. Click OK again to close the dialog box and 
insert the link.

3.

Embedded style sheet
Use an embedded style sheet when you want to define styles for the current page.

To include embedded styles in a Web page, you enclose it in <style> tags. It is also good practice to include comment tags to hide the
styles from older browsers that don’t support CSS.

<style> <!-- h1 {color: blue; } --> </style>

How to create an embedded style sheet

Open the page you want to modify. On the Format menu, click Style.1.

In the Style dialog box, click New. The New Style dialog box opens.2.

In the Name box, type the element you want to create, and then click Format.3.

Click Format, and then select the properties you want to modify from the drop-down menu.4.

When you're done, click OK, and then click OK again to apply the styles.5.
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How to modify an embedded style sheet

Open the page you want to modify. On the Format menu, click Style.1.

In the Style dialog box, click the element you want to modify, and then click Modify.2.

In the Modify Style dialog box, click Format and then select the properties you want to modify from the drop-down menu.3.

When you've completed the modifications, click OK, and then click OK again to apply the styles.4.

Inline style sheet
Use an inline style sheet when you want to apply a style to individual elements on a page.

You apply an inline style directly to the element, affecting everything that is contained within that element. For example, if all of your H1
elements are blue, but there's one that you want to appear red, you'd apply the following inline style rule to that H1 element:

<h1 style="color: red;">Heading</h1>

How to create or modify an inline style sheet

Select the element you want to modify and press CTRL+Q.

In the Quick Tag Selector, click the arrow and select Edit Tag. Then edit the element you want.

CSS references
Using Cascading Style Sheets by Microsoft Office FrontPage MVP David Berry

Guide to cascading style sheets from the Web Design Group

CSS Reference from the World Wide Web Consortium (W3C)
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How to work with code 
in Split view

Open a Web page. Then, click the Split button  at the bottom of document window.1.

After editing the Code pane, refresh the page (press F5), save the page (press CTRL+S), or click 
anywhere in the Design pane to see your changes.

Note    After you edit the Design pane, you don't need to save or refresh the page. It will get
updated automatically.

2.

How to work with code in Code view Open a Web page. At the bottom of the document window, click the Code button  .

Handy display 
options for code

On the Tools menu, click Page Options. Click the Color Coding tab.

You can turn on Word Wrap, so that lines of code don't run off the edge of the page. On the Tools menu, 
click Page Options. Click the General tab, and then select Word wrap at the bottom.

You can turn on line numbers so that each line of code is identified with a number that you can jump to. On 
the Tools menu, click Page Options. Click the General tab, and then select Line numbers at the bottom.

You can turn on the Code View toolbar, which lets you insert temporary bookmarks and provides other 
handy features for working with code. On the View menu, point to Toolbars, and then make sure that the 
Code View toolbar is selected.

How to use the 
IntelliSense lists First you'll need to set up the IntelliSense options. On the Tools menu, click Page Options. Then click the 

IntelliSense tab.
1.

To get the IntelliSense lists to appear automatically as you type HTML, make sure that HTML statement 
completion is selected under Auto Popup. Select Scripting statement completion and Script 
parameter completion too if you want to use IntelliSense lists as you write script.

2.

To have closing tags inserted automatically as you type, select Close tag under Auto Insert. If you want 
your HTML or XSLT values to be surrounded by quotation marks, make sure those options are selected as 
well.

3.

When typing in your code, type a delimiter (<) to see the IntelliSense list and the completion options. If 
the list doesn't appear, press CTRL+L.

4.

How to quickly reformat HTML Right-click the code, and then click Reformat HTML.

How to work with 
temporary bookmarks First, turn on the Code View toolbar. On the View menu, point to Toolbars, and then make sure 

that the Code View toolbar is selected.
1.

Find the line of code you'll be working with often, and insert your cursor inside the line.2.

On the Code View toolbar, click the Toggle Bookmark button  .3.

Notice that the small bookmark is added in the margin to the left of the code.4.

When you've scrolled to another location in the code, you can easily jump back to the bookmark. On 

the Code View toolbar, click either the Next Bookmark button  or the Previous Bookmark

button  .

Tip    You can also press F2 to go to the next bookmark.

5.
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How to insert a table

Position the insertion point where you want to insert the table.1.

On the Table menu, point to Insert, and then click Table.2.

In the Rows box, type the number of rows you want.3.

In the Columns box, type the number of columns you want.4.

Specify other properties such as border size, cell padding, cell spacing, and width.5.

Note    There are other commands you can use when you want to insert a sophisticated table for layout purposes. For more information about
layout tables, see Microsoft FrontPage Help.

Important note about HTML tables and accessibility
Many designers use HTML tables for page layout. However, it is important to know that if you use HTML tables for page layout, your pages may 
not be accessible to people with vision disabilities. This is because people with vision disabilities often use screen readers or Braille displays, and 
these devices don't always read or display layout tables in a logical order.

In order to make your pages more accessible to people with vision disabilities, it is recommended that you use positioning for page layout. For 
more information about positioning, see FrontPage Help.

For more information about creating accessible Web pages, see the W3C Web Content Accessibility Guidelines.

How to change the properties of a table

Click inside the table you want to change.

At the top of your page, the <table> button should appear along with a series of other buttons. (If the buttons don't appear, verify 
that the Quick Tag Selector is turned on using the View menu.)

1.

Point to the <table> button, click the arrow, and then click Tag Properties.2.

Make your changes, and then click OK.3.

How to change the properties of a cell

Click inside the table you want to change.

At the top of your page, the <td> button should appear along with a series of other buttons. (If the buttons don't appear, verify that 
the Quick Tag Selector is turned on using the View menu.)

1.

Point to the <td> button, click the arrow, and then click Tag Properties.2.

Make your changes, and then click OK.3.
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How to insert a table

Position the insertion point where you want to insert the table.1.

On the Table menu, point to Insert, and then click Table.2.

In the Rows box, type the number of rows you want.3.

In the Columns box, type the number of columns you want.4.

Specify other properties such as border size, cell padding, cell spacing, width, etc.5.

Notes   

There are other commands you can use when you want to insert a sophisticated table for layout purposes. For more information about
layout tables, see Microsoft FrontPage Help.

Accessible HTML tables    Many designers use HTML tables for page layout. However, it is important to know that if you use HTML
tables for page layout, your pages may not be accessible to people with vision disabilities. This is because people with vision disabilities 
often use screen readers or Braille displays, and these devices don't always read or display layout tables in a logical order. In order to 
make your pages more accessible to people with vision disabilities, it is recommended that you use positioning for page layout. For 
more information about positioning, see Microsoft FrontPage Help.

For more information about creating accessible Web pages, see the W3C Web Content Accessibility Guidelines.

Three options for table widths

Table 
option

Description

No specified 
width

If you don't specify the width of an HTML table, then the row with the widest contents will determine the width.

Width in 
pixels

This option sets up a "fixed-width table" or a "pixel-based table." Use it when you need precise control over how much space the 
table occupies on the page.

Width in 
percent

The third option is to define the table width as a percentage of the available space. Typically, the available space is the size of 
the browser window. But, if the table is nested within another table, then the width is a percentage of the available space in that 
table.

Three finicky rules for table cells

Rule #1: Sum of the column widths should equal the table width

For the most part, if you specify a width for your table, the sum of the column widths should be equal to the table width. This practice is
especially important if you want your tables to look consistent across different browsers.

Rule #2: Content is king

What we mean by that is, if a cell's content is wider than the specified width of the cell, the content will force the cell beyond that width. Long
words or URLs in your cells can often push your table beyond the width you want. This can also happen if you insert a wide image.

Rule #3: Without content, cells can disappear

If a cell doesn't contain content, it will actually disappear or "collapse" into nothing. That’s why when you insert a new table using FrontPage, a
nonbreaking space (&nbsp;) is automatically placed into each cell behind the scenes.
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Prepare your page

Do one or more of the following:

Click the Design button  at the bottom of the document window.

On the View menu, point to Ruler and Grid, and then make sure that Show Ruler is selected.

On the View menu, make sure that the Quick Tag Selector is turned on.

If you want a tracing image, go to the View menu, point to Tracing Image, and then click Configure to add the image to the page.

If you want a grid, on the View menu, point to Ruler and Grid, and then make sure that Show Grid is selected. You can also 
customize the grid. On the View menu, point to Ruler and Grid, and then click Configure.

Remove the default margins of the page. On the File menu, click Properties, and click the Advanced tab. In the Top Margin box, 
type 0. In the Left Margin box, type 0 as well, and click OK.

Step 1: Draw the layout table

On the Table menu, click Layout Tables and Cells.1.

In the task pane, click the Draw Layout Table button  and draw the table.2.

Adjust the table by typing the new width and height into the Layout Tables and Cells task pane.3.

Step 2: Draw the layout cells

Make sure the <table> button is selected. Then, in the Layout Tables and Cells task pane, click the Draw Layout Cell button

 , and then draw a layout cell inside the table.

1.

To draw additional layout cells, click the Draw Layout Cell button  button each time before you draw the cell.2.

Step 3: Adjust the layout cells

To resize a layout cell

To resize a layout cell, click a resizing handle, and then drag the border into place. If you want to override snapping, press ALT while 
you drag.

Or, on the Table menu, click Cell Formatting. In the Cell Formatting task pane, type new width and height values to match the 
tracing image.

To move a layout cell

To move a layout cell, click the <td> button to select the cell. Then use your arrow keys to nudge it into place. Each time you press 
an arrow key, the cell will move one pixel at a time.

Or, use your mouse to drag the cell. If you want to override snapping, press ALT while you drag the cell.

Step 4: Fill the layout cells

Click the Toggle Pane button  to open the Folder List.1.

Drag images from the Folder List into the layout cells and either type or copy and paste text from other files into the layout cells.2.

Step 5: Finish things up and preview

On the File menu, click Preview in Browser, and then click any browser option.

Important note about HTML tables and accessibility
Many designers use HTML tables for page layout. However, it is important to know that if you use HTML tables for page layout, your pages may 
not be accessible to people with vision disabilities. This is because people with vision disabilities often use screen readers or Braille displays, and 
these devices don't always read or display layout tables in a logical order.

In order to make your pages more accessible to people with vision disabilities, it is recommended that you use positioning for page layout. For 
more information about positioning, see FrontPage Help.

For more information about creating accessible Web pages, see the W3C Web Content Accessibility Guidelines.
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Format a layout table and the layout cells

Before you begin

Do one or more of the following:

Click the Design button  at the bottom of the document window.

On the View menu, make sure that the Quick Tag Selector is turned on.

Add a background color to the layout table

Click anywhere inside the table. On the Quick Tag Selector, point to the <table> button, click the arrow, and then click Tag 
Properties.

1.

Under Background, click the arrow for the Color box, and then choose a color.

Tip    To add a background image to the table, select Use background picture and then click Browse to find the picture.

2.

Press ENTER to close the dialog box and apply your changes.3.

Change the alignment for a layout table

Click anywhere inside the table. On the Quick Tag Selector, click the <table> button.1.

On the Table menu, click Layout Tables and Cells. For Alignment, choose one of the three options available.2.

Format layout cells using the Cell Formatting task pane

Click inside the layout cell you want to change. On the Quick Tag Selector, click the <td> button to select the cell.1.

On the Table menu, click Cell Formatting.2.

At the top of the task pane, click Cell Properties and Borders. Then change the width, height, padding, text alignment, background 
color, borders, or margins.

3.

Use a style from a cascading style sheet

First, create a style in a cascading style sheet. Then link the style sheet to the page you are working on. For detailed information on 
how to do this, see FrontPage Help.

1.

Make sure the Style toolbar is showing. On the View menu, point to Toolbars, and then make sure that Style is selected.2.

Click inside the table or cell that you want to format. Then on the Quick Tag Selector, click either the <table> button or the <td>
to select the table or cell.

3.

On the Style toolbar, in the Class list box, choose the name of the style you set up in the cascading style sheet.4.

Make final touch-ups to a layout table

Set up autostretch

Click the Design button at the bottom of the document window.1.

Click anywhere inside the table. At the top of the document window, click the <table> button.2.

Click the tab of the column you want to stretch, and then click Make Column Autostretch. Or, click the tab of the row you want to 
stretch, and then click Make Column Autostretch.

3.

Use spacer GIFs

Click the Design button at the bottom of the document window.1.

Click anywhere inside the layout table. At the top of the document window, click the <table> button.2.

Click the tab of the column you want to keep consistent, and then click Use Column Spacer Image.3.

On the File menu, click Save. 

The Save Embedded Files dialog box appears. This tells you that FrontPage created an MsSpacer.gif automatically for you when 
you chose Use Column Spacer Image.

4.
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Insert an interactive button

Open a Web page. If you are not in Design view, click the Design button  at the bottom of the document window.1.

Position your pointer where you want the button. On the Insert menu, click Interactive Button.2.

On the Button tab, look through the list of button styles, and choose a style that you like. In the Text box, type some text that you 
want to appear inside the button. In the Link box, type a URL to a page or site.

3.

On the Font tab, choose a font, font style, and font size that you like. You can also change the text color at this time.4.

On the Image tab, change the width and height, if necessary.5.

To create smooth looking images, keep the Make the button a JPEG image... option selected. To create images that have a 
transparent background, click Make the button a GIF image.... Click OK.

6.

On the File menu, click Save. The Save Embedded Files dialog box appears, telling you that there are three files that the page 
needs in order for the button to work. Rename each file to a name that makes sense to you.

7.

Now test the button. On the File menu, point to Preview in Browser, and then click any browser option on the submenu.8.

Notes   

If you delete an interactive button, the associated images are not automatically deleted from your Web site. To quickly find images that 
were left behind, you can use the Unlinked Files report (available when clicking the View menu, Reports submenu, Site Summary
command). In the Unlinked Files report, delete any images that have a 0 in the Links to column.

To make your own custom interactive effects, use the Behaviors task pane (Format menu, Behaviors command.)
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Find and replace text across multiple pages

Before you find and replace text across multiple pages, it's a good idea to make sure that all pages in the site have been saved. A 
quick way to do this is to click Save All on the File menu.

1.

On the Edit menu, click the Replace command.2.

Enter the text that needs to be changed.3.

Enter the replacement text.4.

Click All pages.

Note    The All pages option will be unavailable if you do not have a FrontPage Web site open. For more information, see the course 
Create a FrontPage Web site.

5.

Click Replace all to make all replacements immediately, or click Find In Web Site to review all possible replacements.6.

Include a Web page inside another Web page

Open a FrontPage Web site.1.

Create a new page that is smaller and can easily fit within other pages.2.

Position the insertion point where you want to include the new, smaller page.3.

On the Insert menu, click Web Component, click Included Content, and then double-click Page.

Note    The Page option will be unavailable if you do not have a FrontPage Web site open. For more information, see the course 
Create a FrontPage Web site.

4.

In the Include Page Properties box, type the file name or click Browse to find the file. Then click OK.5.

Fix broken hyperlinks

Open a FrontPage Web site.1.

On the View menu, point to Reports, and then click Site Summary.

Note    Reports are unavailable if you do not have a FrontPage Web site open. For more information, see the course Create a 
FrontPage Web site.

2.

In the list of reports, click Broken Hyperlinks.3.

If you have any external links in your Web site, FrontPage will ask if you want to verify those links. Click Yes to verify them.4.

One or more of the following may occur: 

Internal links that go to missing or misspelled pages will have Broken status. When you double-click a broken link, you can type 
the right file name, or browse to the correct location.

FrontPage will attempt to verify any external links. If links go to valid and available Web sites, they will have OK status. A link 
will have Broken status if the Web site is invalid or unavailable, or if your connection to the Internet was unavailable.

5.

Use variables to automatically update content

Open a FrontPage Web site.1.

On the Tools menu, click Site Settings, and then click the Parameters tab.

Note    The Site Settings command will be unavailable if you do not have a FrontPage Web site open. For more information, see the 
course Create a FrontPage Web site.

2.

Click Add. In the Name box, type a name for the variable (for example, Address). This is what you will call the variable, but Web 
visitors will not see it. In the Value box, type a value for the variable. This is what will be displayed on the page (for example, 111 
Main Street).

3.

Position the insertion point in a page where you want to display the variable. On the Insert menu, click Web Component, click 
Included Content, and in the right pane, double-click Substitution.

4.

In the Substitute with box, click the variable you made.5.
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What to have on hand prior to publishing
Get the following information from your Web hosting company before publishing. This will ensure minimal errors and problems when connecting 
to the Web server.

Get the FTP host name from your hosting company (for example, ftp.example.com).

Get the FTP directory for your files. If your hosting company doesn't specify an FTP directory, then you don't need to specify one 
when publishing.

Get the correct spelling of your home page from your hosting company (for example: index.htm, index.html, default.htm, or
default.html). Rename your home page to this if necessary.

Ask your IT department, help desk, or network administrator if you are allowed to publish with FTP beyond a firewall. Also ask if 
you need to install special software that allows you to publish beyond the firewall.

Make sure you know what your disk space limit is on the Web server.

How to publish with FTP

Part 1: Open a FrontPage Web site

On the File menu, click Open Site.1.

In the Open Site dialog box, use the Look in box to find the folder containing your Web site.2.

Select the folder you want, and then click Open.3.

Part 2: Set up your remote Web site

Click the Web Site tab. At the bottom of the window, click the Remote Web site button.

Tip    You can also access the Remote Web site view on the View menu. Or, you can access it by clicking the Publish command on 
the File menu.

1.

At the top, click Remote Web Site Properties.2.

Under Remote Web server type, click FTP.3.

In the Remote Web site location box, type the FTP host name that was given to you by your hosting company.4.

If your hosting company provided an FTP directory, then type it in the FTP directory box and click OK.

Note    If you were not given an FTP directory, be sure to leave this box blank.

5.

Enter the name and password that your hosting company gave you, and then click OK.

FrontPage will attempt to connect to the server. When it successfully connects, the Local Web site will appear on the left, and the 
Remote Web site will appear on the right.

If you receive an error, try one or more of the following:

Make sure your Internet connection is intact.

If you are behind a firewall, make sure you install special firewall software recommended by your IT department, help desk, or 
network administrator.

Go back to Remote Web Site Properties and review the information you entered to see if there are any typos or 
misspellings.

Make sure you correctly enter the user name and password that was given to you by your hosting company.

Click Passive FTP.

6.

Part 4: Publish files

Do one of the following:
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To publish all new or changed files, click Local to remote in the lower-right corner, and then click the Publish Web site button.

To download files from the remote site to the local site, click Remote to local in the lower-right corner, and then click the Publish 
Web site button.

To synchronize both remote and local sites so that they are the same, click Synchronize in the lower-right corner, and then click the 
Publish Web site button.

Tips

Look at the Status at the bottom of the screen. It will tell you if the publishing process was successful, and when it was completed.

You can also click the link to the log file if you want even more publishing information.

If you don't want to publish a file, right-click it and then click Don't Publish. This will exclude it when you click the Publish Web Site
button.

You can remove a file from either location by selecting it and then clicking the Delete button  .

Click the Refresh button  if more than one person is publishing to the remote Web site and you think your view might not be up
to date.




