Chapter 1

Getting Started With Excel

This chapter will familiarize you with various basic features of Excel. Specific features which you need to solve a problem will be introduced as the need arises. When working with the examples given, you should be at a computer with an open, blank Excel workbook.

Start up Excel using instructions in your local installation of the software. You will see the following screen. Familiarize yourself with the various components of the spreadsheet.

The screen with a grid you are looking at is called a worksheet. You can click on the tabs below to go to other worksheets. These worksheets are part of a workbook with the file name book1.xls, but you can rename it to any file name when you save your file.

If your screen does not exactly resemble the above, don’t be concerned. To display all the features shown on this sample worksheet, go to View > Toolbars and check the standard and formatting toolbars.
Data and Cell References

All information in a spreadsheet is entered through data in cells. Each cell has a unique reference given by its column letter and row number. You will notice that the cell reference box above the column headings says A1. The reference of the cell can easily be figured out by locating the column and row where it belongs.

To move from one cell to another, you can use the arrow keys or select a cell with a mouse click. You can also type <CTRL>g to go to a specific cell reference.

You can work with a range of cells. To select a range, click into the beginning of the range of cells. Hold down the mouse and drag to the end of the range. Release the mouse button. The reference for a range of cells is given by beginning_cell_reference:end_cell_reference

Check it out

- Select the range of cells h42:j48
- Select the range of cells b8:d40

In the examples given below, a spreadsheet fragment with illustrative cell reference(s) will often appear. These are given to make the examples easier to follow. You can of course use any groups of cells you desire to work the examples, as long you change the cell references to reflect your setup.

Formatting Cells

You can type either text or numbers in a cell. Enter some data by first selecting a cell and typing some text or numbers into it. You can use the back arrow to correct the entry. Press <ENTER>. You may then format the cell content as follows:

1 First select the cell in which some data is entered.
2 Choose the style and size of the font by clicking on the font list.
3 Click on the Bold, Italic or Underline option if you wish to format in one of those styles.
4 Click on the left, center, or right justification for text in a cell.
5 If you have entered a number, you may increase or decrease the number of decimal spaces displayed.

Check it out

- Type in some text in a cell and test out the various formatting capabilities.

Correcting Cell Entries

Once you have entered some data in a cell, and pressed <ENTER>, you may later want to edit it. To do this, press the F2 key. You will see the cursor in the cell. Edit by using the backspace key or by using the mouse cursor. Press <ENTER> to accept the new content.

To delete the contents of the cell, select the cell and press the <DELETE> key. If you want to clear the formatting options from a cell, go to Edit > Clear > Format.
Adjusting Cell Width
When you type in text, you may sometimes exceed the width of the cell. To widen a cell, move the mouse along the column you wish to widen to the row with the heading labels at the top of the worksheet. You will see a symbol looking like <-||->. Holding down the left mouse button, you can now widen the column.

Wrapping Text
For aesthetic reasons, you may not want text in a cell to be too wide. In this case, you must wrap the text within the width of a cell. After selecting the cell, go to Format > Cells. Click on the Alignment tab and check the Wrap Text box.

Inserting Rows or Columns
Go to the cell where you want to insert a row or column. Right click the mouse button and choose the Insert option. Click on the appropriate checkbox for inserting rows or columns.

Formulas
Once you have entered data into cells, you will want to perform some operations with them. Basic arithmetic operators are:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Addition</td>
<td>+</td>
</tr>
<tr>
<td>Multiplication</td>
<td>*</td>
</tr>
<tr>
<td>Division</td>
<td>/</td>
</tr>
<tr>
<td>Subtraction</td>
<td>-</td>
</tr>
<tr>
<td>Exponentiation</td>
<td>^</td>
</tr>
</tbody>
</table>

The usual order of operations holds. Using the above operators, you can write formulas which manipulate the data you have entered in cells.

Example 1 Let \( x = 3 \). Compute \( f(x) = x^3 - 4x \).

Solution We need to store the \( x \) value in a cell. We also need to store the \( x^3 - 4x \) result in another cell. Hence, we can make a simple table as follows. Note that you can enter text into a cell as well. Using a spreadsheet makes it easy to annotate your work.
Now, the value of $x$ is contained in the cell $D2$. The value for $f(x)$ is computed by the formula using the cell reference $D2$ in place of $x$. So, the formula for $f(x)$ using cell references is $=d2^3-4*d2$ (Note: $D2$ is the same as $d2$).

To enter this in the spreadsheet:

1. Select the cell $E2$
2. Type the formula $=d2^3-4*d2$ in this cell
3. Press <ENTER>

A formula always begins with an $=$ sign. There should be no space before the $=$ sign and there should be no space between the $=$ sign and the rest of the formula.

Now, change the value of $x$ in $D2$. What happens to the value in $E2$?

Check it out

- Change $f(x)$ to $f(x) = 2x^2 + 1$. Enter this formula in $E2$ using cell references.
- Be careful when entering formulas. Let the value in $a1$ equal some number not equal to 1. What is the output of $f(x)=1/(x-1)$ when incorrectly using the formula $=1/a1-1$? Compare with the correct formula $=1/(a1-1)$.

When you look at a worksheet, you cannot see which cells have formulas and which have numbers. If you want to see all the formulas in the spreadsheet in their respective cells, click Tools > Options. Click on the View tab and check the Formulas box. Close the dialog box, and now your spreadsheet will display all formulas. To go back to the original view, simply unclick the formula box in the View tab.

Check it out

- Display the formula view for the worksheet above.

Copying and Pasting

Now suppose you want to compute $f(x)$ in Example 1 for $x=1,2,3,4,5$. You also want to display all these values simultaneously by creating a table. Instead of typing the formula over and over again, we can copy and paste. This is illustrated in the next example.

Example 2 Compute $f(x)$ for $x=1,2,3,4,5$ and display the results in a table.

Solution Make columns for $x$ and $f(x)$. Enter the $x$ values that you are interested in:

<table>
<thead>
<tr>
<th></th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>x</td>
<td>f(x)</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>3</td>
<td></td>
</tr>
</tbody>
</table>
In the cell \( E2 \), enter the formula for \( f(x) = x^3 - 4x \). This gives the following:

> \begin{array}{|c|c|}
> \hline
> x & f(x) \\
> \hline
> 1 & 1 - 3 \\
> 2 & -3 \\
> 3 & 0 \\
> 4 & 15 \\
> 5 & 48 \\
> 6 & 105 \\
> \hline
> \end{array}

Press <ENTER> after entering the formula, and you will see the value of \( f(1) = -3 \) in the cell \( E2 \).

Since we want to compute the values of \( f(x) \) for the other values of \( x \) as well, we can copy the formula by following the steps below.

**Copying a formula down a column**

1. Select the \( E2 \) cell in the above table. Press <CTRL>c to copy.
2. Select the rest of the \( f(x) \) column, cells \( E3 : E6 \). Press <CTRL>v to paste.

Look in the formula bar for the entries \( E3 : E6 \) and note that the cell references automatically change to the \( x \)-value directly to the left of the \( y \)-value.

**Autofill option**

Another way to copy the formula down the column is to move your mouse to the lower right hand corner of the cell \( E2 \) until you see a small + sign. Then, holding down the left mouse button, drag your mouse down the column to \( E6 \). The formulas will be automatically changed to reflect the new \( f(x) \)-values.

Your table will look like the following, regardless of the method you use to copy the formula:
Check it out

- Change \( f(x) \) to \( f(x) = -x^2 + 4 \). Remember to recopy the new formula down the column.

## File Operations

Now that you have entered various items in your workbook, you will want to save and/or print the file. The following table summarizes how to perform various operations with your Excel file.

<table>
<thead>
<tr>
<th>Operation</th>
<th>How to perform</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open new file</td>
<td>Menu &gt; File &gt; New</td>
</tr>
<tr>
<td>Open old file</td>
<td>Menu &gt; File &gt; Open; then follow dialog box</td>
</tr>
<tr>
<td>Saving new file</td>
<td>Menu &gt; File &gt; Save As; then follow dialog box</td>
</tr>
<tr>
<td>Saving to current file</td>
<td>Menu &gt; File &gt; Save or &lt;CTRL&gt;s</td>
</tr>
<tr>
<td>Printing file</td>
<td>Menu &gt; File &gt; Print or &lt;CTRL&gt;p</td>
</tr>
<tr>
<td>Page setup</td>
<td>Menu &gt; File &gt; Page Setup</td>
</tr>
</tbody>
</table>

### Print preview and formatting your worksheet

Within the page setup option outlined above, you can set headers, footers, margins, and orientation of the page (portrait or landscape). You can then use File > Print Preview to preview your final output. Although it is preferable to have the gridlines visible on the computer, you should normally not print out the gridlines. The default option in Excel 2000 is to suppress the printing of gridlines.

You may want to outline your tables with borders. The border formatting icon on the formatting bar will show you various options.

### Tables in Excel

In order to use the graphing features of Excel, you will first need to generate tables of x and y values. In this section, you will learn how to easily generate equally spaced entries for use as x-values.
Example 1 Generate a table of values from -2 to 3 in increments of 0.5.

Remark We could of course do this manually, but that would be laborious. Excel can automatically generate this table by using the Fill feature.

Solution

Steps to create a table of x-values

1 Type a heading label x in cell A1.
2 Type in the first value of -2 in the cell A2.
3 In cell A3, type in the next value of -1.5, since our increments are in steps of 0.5. Now that you have entered a starting value and a value with the increment, Excel can generate the rest of the table.

4 Select the cells A2:A3. Move mouse to lower right corner until you see a plus sign. Your screen should resemble the following figure:

5 Drag the mouse all the way down the column to A12. You should now see a filled column of values from -2 to 3 in increments of 0.5, like the one below.
Example 2  Suppose we want to generate x and y values in a table. For example, find \( f(x) = 3x - 2 \) for the x-values given in the table above.

Solution  Follow the steps outlined below.

Steps for creating table with x and y values
1  Make a table with x and f(x) column headings.
2  Fill the x-column as directed in Example 1.
3  Next, we need to fill in values for f(x).
   a  The first y-value will have the formula \( =3*a^2-2 \). Type it into the cell \( \text{B2} \).
   b  We next fill the entire f(x) column by simply copying and pasting the formula in the \( \text{B2} \) cell:
      Select the \( \text{B2} \) cell in the above table. Press <CTRL>c to copy.
      c  Select the rest of the f(x) column. Press <CTRL>v to paste. Note that the cell references automatically change to the x-value directly to the left of the y-value.
4  Alternatively, we could have used the Autofill method outlined in the Copying and Pasting section.
5  Your table should resemble the one below

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>x</td>
</tr>
<tr>
<td>2</td>
<td>-2</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>x</td>
</tr>
<tr>
<td>2</td>
<td>-2</td>
</tr>
<tr>
<td>3</td>
<td>-1.5</td>
</tr>
<tr>
<td>4</td>
<td>-1</td>
</tr>
<tr>
<td>5</td>
<td>-0.5</td>
</tr>
<tr>
<td>6</td>
<td>0</td>
</tr>
<tr>
<td>7</td>
<td>0.5</td>
</tr>
<tr>
<td>8</td>
<td>1.0</td>
</tr>
<tr>
<td>9</td>
<td>1.5</td>
</tr>
<tr>
<td>10</td>
<td>2</td>
</tr>
<tr>
<td>11</td>
<td>2.5</td>
</tr>
</tbody>
</table>

Copyright © Houghton Mifflin Company. All rights reserved.
Check it out

- Change $f(x)$ to $f(x)=-x^2+4$. Remember to recopy the new formula down the column.
- Create a table of $x$ and $y$ values for $f(x)=2x-4$ for values of $x$ between -2 and 3 in increments of 1.

Some Common Errors

Grayed out option boxes
This happens when you try to do something with a cell, but are still working with that cell. Click out of the cell and click back in and now select the option.

#REF, #####, #DIV/0 and other error messages
#REF usually indicates an erroneous cell reference. Check your formulas in formula view if necessary.

##### means that the number did not fit in the cell. Simply widen the cell to suitable width.

#DIV/0 means you’re dividing by zero. Check your formulas and their references.

#NAME? usually indicates an invalid name of a function.

Described menu option does not appear in pull-down menu
This is not really an error, but rather a new “feature” in Excel 2000. If you do not see a menu option listed in the pull-down menu, you should click on the double arrows pointing down - it will then list the complete set of options.
Graphing a Single Function

To graph functions in Excel, you must first create a table of data with the information about the x and y values. You then use Chart Wizard to create the plot. The following example will take you through the process step by step.

Example 1  Graph the function \( f(x) = 2x^2 + x \) on the interval \([-2,2]\).

Solution  Follow the steps outlined below.

Creating the graph of a function

1  First create a table of x and y values as explained in the Tables section of Chapter 1. The y-values are given by the formula for \( f(x) \). The formulas for the first two y-values are given as an illustration.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>x</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>1.5</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>0.5</td>
</tr>
<tr>
<td>6</td>
<td>0</td>
</tr>
<tr>
<td>7</td>
<td>0.5</td>
</tr>
<tr>
<td>8</td>
<td>1</td>
</tr>
<tr>
<td>9</td>
<td>1.5</td>
</tr>
<tr>
<td>10</td>
<td>2</td>
</tr>
</tbody>
</table>

2  Select the range of x and y values which you wish to plot. For this example, it is the range A1:B10. We select the column headings as well as the numbers.
3. Click on the ChartWizard icon, which is on the menu bar with a bar graph icon. You will see the following dialog box.

4. Select the X-Y (Scatter) chart type with the smoothed line with no markers subtype. The dialog box will then look as follows:
5 Click the Next button. You will see the following dialog box. Examine the boxes to see the correct information is entered.

![Chart Wizard - Step 2 of 4 - Chart Source Data](chart_wizard_step_2.png)

6 Click the Next button. You will see a dialog box for Step 3. Enter labels for the x-axis, y-axis as well as a title for the graph. Click Next.

![Chart Wizard - Step 3 of 4 - Chart Options](chart_wizard_step_3.png)
You are now at Step 4 of the ChartWizard, the final step. In this step, you will be asked where to place the graph. By default, the option to place the chart within the current worksheet will be checked. Just click Finish and you will see a graph like the following.

**Check it out**

- Graph the function \( f(x) = 2x^3 \) on the interval \([-2,1]\).

**Graphing More than One Function**

To graph more than one function on the same plot with the same range of \( x \)-values, simply create a table with multiple column headings, with one heading for each function. The next example illustrates this.

**Example 2** Graph \( f(x) = x^2 \) and \( g(x) = x^3 \) on the interval \([-2,2]\).

**Solution** Follow the steps outlined below to graph more than one function.

**Steps to graph more than one function on the same plot**

1. Create the following table with \( x \)-spacing of 0.5. Create the values for \( f(x) \) and \( g(x) \) with formulas. The formulas are given in the first row as an illustration. Note that \( f(x) \) and \( g(x) \) each have a separate column.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>x</td>
<td>f(x)</td>
<td>g(x)</td>
</tr>
<tr>
<td>2</td>
<td>-2</td>
<td>=a2^2</td>
<td>=a2^3</td>
</tr>
<tr>
<td>3</td>
<td>-1.5</td>
<td>2.25</td>
<td>-3.375</td>
</tr>
<tr>
<td>4</td>
<td>-1</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>5</td>
<td>-0.5</td>
<td>0.25</td>
<td>-0.125</td>
</tr>
<tr>
<td>6</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>7</td>
<td>0.5</td>
<td>0.25</td>
<td>0.125</td>
</tr>
</tbody>
</table>
2. Select the range of cells A1:C10.

3. Click on the ChartWizard icon and follow steps 3-7 in the previous section. You will get the following graph.

Graphing Options

Excel has many options to adjust the way your plot looks. Once you have placed the chart in the worksheet, you can right click into the chart to list a variety of options. Here, we will briefly outline some major options.

Changing scale
You may want to adjust the scale on the x and/or y axes.

Changing scale on chart in previous example
1. Double click the x-axis. You will see a dialog box.
2. Click on the Scale tab.
3 Change the Minimum and Maximum values and uncheck the corresponding Auto boxes, as shown below:

![Format Axis dialog box](image)

4 Click OK and the x-axis scale will be adjusted on your chart.

5 You can do a similar scaling on the y-axis.

### Changing marker styles

To change the line color and or marker styles in a plot, double click into the curve you want to change. You will get a dialog box labeled Format Data Series. Click on the Patterns tab and choose the options you desire.

### Deleting background shading

By default, Excel provides background shading in all the charts. This can at many times obscure the graphs you generate. To get rid of the shading, double click into the plot area and check “None” for format of plot area. Many of the graphs generated in this manual have used this option to get rid of the background shading.

### Graphing Discontinuous Functions

When graphing functions in Excel, all the values listed in the table will be connected together by a curve. If a graph is discontinuous at some point at some x-value, you must leave the corresponding f(x) value blank. Then, Excel will not connect the values.

**Example** Graph the function f(x)=1/(1-x).

**Solution** Note that this function is discontinuous at x=1.

**Steps to plot a discontinuous function**

1. Generate a table for x from -1 to 1 and from x=1 to 3, following the directions for generating tables in the previous sections. You will want to have more points near x=1.
2. Generate the f(x) values and remember to leave a blank cell for the f(x) value for x=1.
3 Your table will resemble the following:

<table>
<thead>
<tr>
<th>x</th>
<th>f(x)</th>
</tr>
</thead>
<tbody>
<tr>
<td>-1</td>
<td>-0.5</td>
</tr>
<tr>
<td>-0.5</td>
<td>-0.666667</td>
</tr>
<tr>
<td>0</td>
<td>-1</td>
</tr>
<tr>
<td>0.5</td>
<td>-2</td>
</tr>
<tr>
<td>0.75</td>
<td>-4</td>
</tr>
<tr>
<td>0.9</td>
<td>-10</td>
</tr>
<tr>
<td>1</td>
<td></td>
</tr>
<tr>
<td>1.1</td>
<td>10</td>
</tr>
<tr>
<td>1.25</td>
<td>4</td>
</tr>
<tr>
<td>1.5</td>
<td>2</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
</tr>
<tr>
<td>2.5</td>
<td>0.666667</td>
</tr>
<tr>
<td>3</td>
<td>0.5</td>
</tr>
</tbody>
</table>

4 Note that there is no f(x) value for x=1.

5 Select the table and plot using ChartWizard. You will get a plot similar to the following:

Check it out

- Plot the function \( f(x) = \frac{1}{(x-2)^2} \)

**Plotting Functions using Cases**

Sometimes, functions will have different definitions depending on the domain. To generate the table of values for such functions, simply enter the appropriate formula for \( f(x) \) for the corresponding \( x \)-values. You should be careful not to blindly copy a single formula down the entire column for these types of functions.